# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$//gm;t' <<< "59
100
100.000000
101
5
9
19
12.2
4.0
0
"