using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$";
string substitution = @"";
string input = @"59
100
100.000000
101
5
9
19
12.2
4.0
0
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}