import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:100(?:\\.0*)?)|(?:\\d|[1-9]\\d)(?:\\.\\d*)?)$";
final String string = "59\n"
+ "100\n"
+ "100.000000\n"
+ "101\n"
+ "5\n"
+ "9\n"
+ "19\n"
+ "12.2\n"
+ "4.0\n"
+ "0\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}