re = /^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$/m
str = '59
100
100.000000
101
5
9
19
12.2
4.0
0
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result