use strict;
my $str = '59
100
100.000000
101
5
9
19
12.2
4.0
0
';
my $regex = qr/^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";