// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$").unwrap();
let string = "59
100
100.000000
101
5
9
19
12.2
4.0
0
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}