import Foundation
let pattern = #"^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
59
100
100.000000
101
5
9
19
12.2
4.0
0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)