package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$`)
var str = `59
100
100.000000
101
5
9
19
12.2
4.0
0
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}