#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:100(?:\.0*)?)|(?:\d|[1-9]\d)(?:\.\d*)?)$"
Local $sString = "59" & @CRLF & _
"100" & @CRLF & _
"100.000000" & @CRLF & _
"101" & @CRLF & _
"5" & @CRLF & _
"9" & @CRLF & _
"19" & @CRLF & _
"12.2" & @CRLF & _
"4.0" & @CRLF & _
"0" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)