import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)\\\\{1,2}n";
final String string = "this is a sample\\\\nstring\\\\\\\\ncontaining\\nall cases\\n\\\\n\\n\\\\\\n!\n\n"
+ "this is a sample<br>string\\\\\\\\ncontaining<br>all cases<br><br><br>!";
final String subst = "<br>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}