use strict;
my $str = 'this is a sample\\\\nstring\\\\\\\\ncontaining\\nall cases\\n\\\\n\\n\\\\\\n!
this is a sample<br>string\\\\\\\\ncontaining<br>all cases<br><br><br>!';
my $regex = qr/(?<!\\)\\{1,2}n/p;
my $subst = '<br>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";