import re
regex = re.compile(r"(?<!\\)\\{1,2}n")
test_str = ("this is a sample\\\\nstring\\\\\\\\ncontaining\\nall cases\\n\\\\n\\n\\\\\\n!\n\n"
"this is a sample<br>string\\\\\\\\ncontaining<br>all cases<br><br><br>!")
subst = "<br>"
result = regex.sub(subst, test_str)
if result:
print(result)