const regex = new RegExp('(?<!\\\\)\\\\{1,2}n', 'g')
const str = `this is a sample\\\\nstring\\\\\\\\ncontaining\\nall cases\\n\\\\n\\n\\\\\\n!
this is a sample<br>string\\\\\\\\ncontaining<br>all cases<br><br><br>!`;
const subst = `<br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);