$re = '/(?<!\\\\)\\\\{1,2}n/';
$str = 'this is a sample\\\\nstring\\\\\\\\ncontaining\\nall cases\\n\\\\n\\n\\\\\\n!
this is a sample<br>string\\\\\\\\ncontaining<br>all cases<br><br><br>!';
$subst = "<br>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;