import Foundation
let pattern = #"(?<!\\)\\{1,2}n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
this is a sample\\nstring\\\\ncontaining\nall cases\n\\n\n\\\n!
this is a sample<br>string\\\\ncontaining<br>all cases<br><br><br>!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)