re = /(?<!\\)\\{1,2}n/
str = 'this is a sample\\\\nstring\\\\\\\\ncontaining\\nall cases\\n\\\\n\\n\\\\\\n!
this is a sample<br>string\\\\\\\\ncontaining<br>all cases<br><br><br>!'
subst = '<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result