using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfile (?i)([a-z_][a-z0-9_]*+|""(?:[^""]|(?<=\\)"")*+""|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)";
string substitution = @"(\1 as «class furl»)";
string input = @"set filePath to (path to desktop as text) & ""Test.txt""
set theText to read file filePath";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}