$re = '/\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\\\)")*+"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)/um';
$str = 'set filePath to (path to desktop as text) & "Test.txt"
set theText to read file filePath';
$subst = "(\1 as «class furl»)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;