import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\)")*+"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
set filePath to (path to desktop as text) & "Test.txt"
set theText to read file filePath
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(\1 as «class furl»)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)