import re
regex = re.compile(r"\bfile (?i)([a-z_][a-z0-9_]*+|\"(?:[^\"]|(?<=\\)\")*+\"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)", flags=re.UNICODE | re.MULTILINE)
test_str = ("set filePath to (path to desktop as text) & \"Test.txt\"\n"
"set theText to read file filePath")
subst = "(\\1 as «class furl»)"
result = regex.sub(subst, test_str)
if result:
print(result)