use strict;
my $str = 'set filePath to (path to desktop as text) & "Test.txt"
set theText to read file filePath';
my $regex = qr/\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\)")*+"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)/ump;
my $subst = '(\\1 as «class furl»)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";