const regex = /\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\)")*+"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)/gum;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\\\)")*+"|\\([^()]*+(?:\\([^()]*+(?:\\([^()]*+\\)[^()]*+)*+\\)[^()]*+)*+\\)|\\|[^|]*+\\|)', 'gum')
const str = `set filePath to (path to desktop as text) & "Test.txt"
set theText to read file filePath`;
const subst = `(\1 as «class furl»)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);