import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfile (?i)([a-z_][a-z0-9_]*+|\"(?:[^\"]|(?<=\\\\)\")*+\"|\\([^()]*+(?:\\([^()]*+(?:\\([^()]*+\\)[^()]*+)*+\\)[^()]*+)*+\\)|\\|[^|]*+\\|)";
final String string = "set filePath to (path to desktop as text) & \"Test.txt\"\n"
+ "set theText to read file filePath";
final String subst = "(\\1 as «class furl»)";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}