re = /\bfile (?i)([a-z_][a-z0-9_]*+|"(?:[^"]|(?<=\\)")*+"|\([^()]*+(?:\([^()]*+(?:\([^()]*+\)[^()]*+)*+\)[^()]*+)*+\)|\|[^|]*+\|)/m
str = 'set filePath to (path to desktop as text) & "Test.txt"
set theText to read file filePath'
subst = '(\\1 as «class furl»)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result