# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*\*(.+?)\*\*/[b]$1[\/b]/g;t' <<< "This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**."