const regex = new RegExp('\\*\\*(.+?)\\*\\*', 'g')
const str = `This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**.`;
const subst = `[b]$1[/b]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);