use strict;
my $str = 'This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**.';
my $regex = qr/\*\*(.+?)\*\*/p;
my $subst = '[b]$1[/b]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";