// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\*\*(.+?)\*\*").unwrap();
let string = "This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**.";
let substitution = "[b]$1[/b]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}