import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*\\*(.+?)\\*\\*";
final String string = "This is **bold** but this is also **bold**.\n"
+ "This too is **bold** but and so is this**bold**.";
final String subst = "[b]$1[/b]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}