import Foundation
let pattern = #"\*\*(.+?)\*\*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[b]$1[/b]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)