$re = '/\*\*(.+?)\*\*/';
$str = 'This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**.';
$subst = "[b]$1[/b]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;