#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\*\*(.+?)\*\*"
Local $sString = "This is **bold** but this is also **bold**." & @CRLF & _
"This too is **bold** but and so is this**bold**."
Local $sSubst = "[b]$1[/b]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)