using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*\*(.+?)\*\*";
string substitution = @"[b]$1[/b]";
string input = @"This is **bold** but this is also **bold**.
This too is **bold** but and so is this**bold**.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}