# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.{10,}$()/$1(\$1)is for replace all text with nothing (remoove all text)/gm;t' <<< "1234567890"