// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.{10,}$()").unwrap();
let string = "1234567890";
let substitution = "$1(\\$1)is for replace all text with nothing (remoove all text)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}