using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{10,}$()";
string substitution = @"$1(\$1)is for replace all text with nothing (remoove all text)";
string input = @"1234567890";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}