re = /^.{10,}$()/m
str = '1234567890'
subst = '$1(\\$1)is for replace all text with nothing (remoove all text)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result