$re = '/^.{10,}$()/m';
$str = '1234567890';
$subst = "$1(\$1)is for replace all text with nothing (remoove all text)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;