import Foundation
let pattern = #"^.{10,}$()"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1234567890"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1(\$1)is for replace all text with nothing (remoove all text)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)