#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.{10,}$()"
Local $sString = "1234567890"
Local $sSubst = "$1(\$1)is for replace all text with nothing (remoove all text)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)