const regex = /^.{10,}$()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{10,}$()', 'gm')
const str = `1234567890`;
const subst = `$1(\$1)is for replace all text with nothing (remoove all text)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);