use strict;
my $str = '1234567890';
my $regex = qr/^.{10,}$()/mp;
my $subst = '$1(\\$1)is for replace all text with nothing (remoove all text)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";