using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\bclsx\s*\(\s*{?[\""\']([_a-zA-Z0-9\s\-\:\/]+)[\""\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))";
string input = @"<div className=""mx-auto sm:px-5 container""> hello </div>
tw={""hello""}
<div className={
(type === ""fixed"")
? clsx("" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container"", className)
: clsx(""container flex flex-col"", className)
}>
{children} clsx({""hello""})
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}