package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))`)
var str = `<div className="mx-auto sm:px-5 container"> hello </div>
tw={"hello"}
<div className={
(type === "fixed")
? clsx(" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container", className)
: clsx("container flex flex-col", className)
}>
{children} clsx({"hello"})
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}