const regex = /(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bclsx\\s*\\(\\s*{?[\\"\\\']([_a-zA-Z0-9\\s\\-\\:\\\/]+)[\\"\\\'])|(?:\\btw\\\\s*([_a-zA-Z0-9\\s\\-\\:\\\/]*))', 'gm')
const str = `<div className="mx-auto sm:px-5 container"> hello </div>
tw={"hello"}
<div className={
(type === "fixed")
? clsx(" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container", className)
: clsx("container flex flex-col", className)
}>
{children} clsx({"hello"})
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}