import Foundation
let pattern = #"(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div className="mx-auto sm:px-5 container"> hello </div>
tw={"hello"}
<div className={
(type === "fixed")
? clsx(" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container", className)
: clsx("container flex flex-col", className)
}>
{children} clsx({"hello"})
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)