# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))"
test_str = ("<div className=\"mx-auto sm:px-5 container\"> hello </div>\n\n"
"tw={\"hello\"}\n\n"
"<div className={\n"
" (type === \"fixed\")\n"
" ? clsx(\" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container\", className)\n"
" : clsx(\"container flex flex-col\", className)\n"
" }>\n"
" {children} clsx({\"hello\"})\n"
" </div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.