import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bclsx\\s*\\(\\s*\\{?[\\\"\\']([_a-zA-Z0-9\\s\\-\\:\\/]+)[\\\"\\'])|(?:\\btw\\\\s*([_a-zA-Z0-9\\s\\-\\:\\/]*))";
final String string = "<div className=\"mx-auto sm:px-5 container\"> hello </div>\n\n"
+ "tw={\"hello\"}\n\n"
+ "<div className={\n"
+ " (type === \"fixed\")\n"
+ " ? clsx(\" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container\", className)\n"
+ " : clsx(\"container flex flex-col\", className)\n"
+ " }>\n"
+ " {children} clsx({\"hello\"})\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}