use strict;
my $str = '<div className="mx-auto sm:px-5 container"> hello </div>
tw={"hello"}
<div className={
(type === "fixed")
? clsx(" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container", className)
: clsx("container flex flex-col", className)
}>
{children} clsx({"hello"})
</div>';
my $regex = qr/(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\s*([_a-zA-Z0-9\s\-\:\/]*))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}