$re = '/(?:\bclsx\s*\(\s*{?[\"\']([_a-zA-Z0-9\s\-\:\/]+)[\"\'])|(?:\btw\\\\s*([_a-zA-Z0-9\s\-\:\/]*))/m';
$str = '<div className="mx-auto sm:px-5 container"> hello </div>
tw={"hello"}
<div className={
(type === "fixed")
? clsx(" flex flex-col px-12 mx-auto sm:px-5 container md:px-10 xl:px-24 container", className)
: clsx("container flex flex-col", className)
}>
{children} clsx({"hello"})
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);